[fso] disable led blinking?

arne anka openmoko at ginguppin.de
Thu Jul 23 11:26:48 CEST 2009

solved while writing, dbus calls take longer than i had expected.
for details see below.

> Call SetBrightness 0.

been there. done that. no change (well, it seems to stop for a few  
seconds, but then it blinks again).

in my autosuspend rule chain i do

trigger: IdleState()
filters: HasAttr(status, "lock")
actions: SetLed("gta02_power_blue", "blink")

to have some visual feedback that trhe fr is about to suspend (when it  
reaches idle state "suspend").
the fr thus suspends with a blinking blue led and resumes with a blinking  
blue led.
when pluggin in usb, charging starts and orange led is enabled, steadily  
-- but still the blue led blinks.

since the fr would autosuspend nevertheless, to make it stay awake i got a  
trivial while loop, triggering idle status "idle" every 15s.

while true ; do sleep 15 ; mdbus -s  org.freesmartphone.odeviced  
org.freesmartphone.Device.IdleNotifier.SetState idle ; done

the timeouts in frameworkd.conf are

idle = 10
idle_dim = 20
idle_prelock = 12
lock = 2
suspend = 15

if i do frinst
SetBrightness 0
the blue led is off for a few seconds, but starts again.

my idea was, that 15s are too long and the fr nevertheless enters lock,  
but idle_dim+idle_prelock alone account for 32s -- thus the fr should  
never hit "lock".
but having a close look at the frameworkd log shows, that indeed 15s are  
to long. apparently dbus needs far more time and thus the fr hits lock  
changing to 10s seems to fit.

More information about the community mailing list