[shr-u] navit - howto config navit.xml

Davide Scaini dscaini at gmail.com
Sun Jul 26 02:00:53 CEST 2009

"what the frak"
you were [you are] right!
i just disabled this default mapset and now 'it works' ... just try to
increase our statistics.

       <!-- If you dont want to use the sample map, either set
enabled="no" in the next line or remove the xml file from the maps
directory -->
        <mapset enabled="no">
            <xi:include href="$NAVIT_SHAREDIR/maps/*.xml"/>

we indeed should mention this in the wiki

On 7/25/09, pike <pike-openmoko at kw.nl> wrote:
> Hi
>> I'm having this same issue.  Navit starts just fine.  I start if from
>> a terminal and there are no errors, but neither are there maps.  I have
>> the following line in my ~/.navit/navit.xml (startup messages show me
>> it's using this file):
>> <mapset enabled="yes">
>>    <map type="binfile" enabled="yes"
>> data="/media/mmcblk0p2/root/Maps/Navit/planet-080928.bin" />
>> </mapset>
> I dont know if it helps you, but I had the
> same until I *disabled* the demo mapset. It
> seems only one mapset is allowed (perhaps,
> or perhaps its something else - it doesnt mention
> this in the wiki so i always assume i'm
> crazy - if this helps we should update
> the om wiki page to mention this, ehr, feature)
> you *can* put multiple maps in one mapset, though.
> good luck!
> *-pike
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

More information about the community mailing list