Is your GPS working today?

Alex (Maxious) Sadleir maxious at
Mon Jul 27 01:33:34 CEST 2009

On Mon, Jul 27, 2009 at 5:22 AM, Sebastian Krzyszkowiak
<seba.dos1 at> wrote:
> On Sun, Jul 26, 2009 at 21:15, The Digital
> Pioneer<digitalpioneer at> wrote:
> > Nope, my GPS is dead in SHR-U. I've upgraded since it last worked, but no
> > go.
> >
> > I've got an error in dmesg, the same as Vikas'.
> >
> > Vikas: You know, the '...' in your error there actually only substitutes for
> > one zero. ;) There are 7 zeros in the code.
> I'm asking, cause my GPS stopped to work about 8 hours ago. Without
> any upgrade, without any configuration change (or even other change),
> just while logging cells to openBmap. And when I had problems with GPS
> before (rxerr), they started exactly when people started to complain
> at maillist, and it worked again when people stopped, without my work
> nor upgrade...

I upgraded my SHR just yesterday (hey! my terminal is a different
color scheme?!) and I have rxerr in dmesg *and* GPS works fine in
TangoGPS. I thought TangoGPS was a little slow getting a fix today but
by the time I opened omgps to look closer at the satelite data, it was
3D fix.

[   46.875000] Restarting tasks ... done.
[   48.660000] rxerr: port=1 ch=0x00, rxs=0x0000000c
[   51.645000] rxerr: port=1 ch=0x00, rxs=0x0000000c
[   55.950000] rxerr: port=1 ch=0x00, rxs=0x0000000c

I suspended the phone once before using it today (I think that's the
"Restarting tasks") and I have a 4GB SDHC memory card.
Hope that helps!

More information about the community mailing list