Unable to boot on SHR or OM2009 after installing Android Beta 7

Yorick Moko yorickmoko at gmail.com
Thu Jun 4 22:40:29 CEST 2009

but i'm using qi,
and i have the kernel in the /boot directory on NAND,
that should work without flashing the kernel...
anyway, I will also try this

On Thu, Jun 4, 2009 at 10:25 PM, Yann SLADEK <yann.sladek at free.fr> wrote:
> Ok my fault the problem come from me and nothing is related to Android
> I didn't notice that when flashing fs and kernel together, kernel
> flashing wasn't done cause a USB reset (according to neotool)
> When I flashed kernel only, everything is working great
> Sorry for disturbance
>> Jan Vlug <jan.public at famvlug.nl> writes:
>>> Do I understand correctly that you were not able to flash QI into NAND?
>>> Maybe a Koolu bootloader is causing the strange behavior...
>>> BTW do you know whether the NAND is partitioned as well?
>>> Maybe an experienced bootloader guy can test installing Koolu Android and reverting back to SHR or
>>> om2009 to investigate the issue?
>>> It took me quite some experimentation, trial and error to get my phone back to normal.
>> One can't easily do anything with NOR u-boot. It does its own
>> computation of NAND partitions. If koolu has some special bootloader
>> (i guess it's a Qi fork) just boot to NOR and replace Koolu's version
>> with stock OM's Qi. Easy as that.
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

More information about the community mailing list