[shr-u] wpa-exiting with code 1 ???

Fox Mulder Quakeman1 at gmx.net
Thu Jun 25 16:57:01 CEST 2009

With the latest shr kernel it also didn't work for me. It seems that the
kernel isn't the problem at all. So i installed shr unstable (for the
first time) to try it there. And surprisingly it worked right out of the
box. :)
So i think that maybe my wpa_supplicant.conf file isn't working anymore
but i never changed it since the time it was working nicely with 2.6.24

One big problem with wlan still exists. When i ping my server the time
fluctuates from ~15ms to ~4000ms and i got additional packet loss. I can
see this effect for example when i ssh into my freerunner or download
anything from it.

 So something still must be wrong but i don't know what. My Wlan AP is
working right which i verified with a second pc connected through wlan.

Anybody else experience such odd wlan behaviour?


Fox Mulder wrote:
> Ok, than it should be the latest kernel from [1].
> The kernel there is from June 15th [2].
> I will try this kernel with debian and maybe wlan works better than
> andy-tracking from [3]. :)
> Ciao,
>      Rainer
> [1]http://build.shr-project.org/shr-unstable/images/om-gta02/
> [2]uImage-2.6.29-oe10+gitr119819+5a6ed99264c704e517ac312283c58204ee38fee5-r3.5-om-gta02.bin
> [3]http://git.openmoko.org/?p=kernel.git;a=shortlog;h=andy-tracking
> Jakob wrote:
>> i'm using the latest kernel provided by shr. It's from June 15th. I
>> don't know on what the kernel is based on.
>> jake
>> On 6/21/09, Davide Scaini <dscaini at gmail.com> wrote:
>>> ok,
>>> imho it's a mixture of kernel and wpa/shr version... i had a shr-u well
>>> working with the kernel i mentioned, but latest shr-u is _really_ nicer! so,
>>> i would like to have the wifi working with that... if possible.
>>> @Jakob: which kernel do you use, please?
>>> ...it seems to me an hard balancing...
>>> d
>>> On Sun, Jun 21, 2009 at 3:17 PM, Fox Mulder <Quakeman1 at gmx.net> wrote:
>>>> Do you know which kernel you use where wlan and wpa is working?
>>>> Because i use the latest andy-tracking (in debian) for a few months now
>>>> and wlan with wpa isn't working since than. But i don't exactly know if
>>>> the problem is the kernel or wpa_supplicant or something else. Last time
>>>> it worked was with the deprecated 2.6.24 kernel series. :(
>>>> Ciao,
>>>>     Rainer
>>>> Jakob wrote:
>>>>> i don't have a problem using wlan with wpa on latest shr-unstable. I
>>>>> use mofi (included in shr) to connect to my wlan-router.

More information about the community mailing list