[shr-u] wpa-exiting with code 1 ???

Al Johnson openmoko at mazikeen.demon.co.uk
Thu Jun 25 20:08:34 CEST 2009

On Thursday 25 June 2009, Fox Mulder wrote:
> Al Johnson wrote:
> > On Thursday 25 June 2009, Fox Mulder wrote:
> >> One big problem with wlan still exists. When i ping my server the time
> >> fluctuates from ~15ms to ~4000ms and i got additional packet loss. I can
> >> see this effect for example when i ssh into my freerunner or download
> >> anything from it.
> >>
> >>  So something still must be wrong but i don't know what. My Wlan AP is
> >> working right which i verified with a second pc connected through wlan.
> >>
> >> Anybody else experience such odd wlan behaviour?
> >
> > There were reports that some APs don't play nicely with the power saving
> > enabled on the wifi chip. You could see if it's any more reliable with:
> > 	iwconfig eth0 power off
> > or
> > 	wmiconfig -i eth0 --power maxperf
> Wow you were right with the first guess.
> After i did "wmiconfig -i eth0 --power maxperf" my average Ping goes
> from 583.394ms with packet loss to 13.462ms with no packet loss. :)
> Now i just have to find the right location where i could execute the
> command. Do i have to execute it every time i enable wlan or just once
> after booting?

Probably every time since the recent kernel seems to shut the chip down on 
ifdown (more or less) and reinitialise on ifup. Unless I've completely 
misunderstood the bug report for wifi only working once...

As to where to do it, it probably depends on how you manage your network 
connections. The traditional debian way is to specify it as a post-up command 
in /etc/network/interfaces. WiCD, NetworkManager, connman or whatever will 
presumably have their own equivalent.

More information about the community mailing list