linphone 3.1.0

Michele Brocco ssj2micvm at
Thu Jun 25 23:40:25 CEST 2009

On Thu, Jun 25, 2009 at 11:04 AM, Al
Johnson<openmoko at> wrote:
> On Wednesday 24 June 2009, MicVM wrote:
>> Al Johnson wrote:
>> > On Wednesday 25 March 2009, Paul Fertser wrote:
>> >> > Problems:
>> >> > * I haven't got it to do sound yet - it seems unhappy with the alsa
>> >> > device capabilities. I don't know if this is a configuration issue or
>> >> > a fundamental problem.
>> >>
>> >> I guess you face the same issue with borked /etc/asound.conf as
>> >> others. It has dmix as the default device, and dmix obviously doesn't
>> >> support recording. Probably you can remove /etc/asound.conf altogether
>> >> or try to mimic configuration of any desktop distro. Or just configure
>> >> linphone to use hw:0,0 by default.
>> >>
>> >> Also, don't forget that a special voip.state should be loaded before
>> >> trying to input/output sound. It uses DAI mode 10 and arecord -D
>> >> hw:0,0 | aplay -D hw:0,0 is known to work.
>> >
>> > I suspected as much, but couldn't confirm at the time. I had only given
>> > it a
>> > cursory check with the config that used to work for me with v1.6 and
>> > 2007.2.
>> > Now I can confirm it works using Brian Code's asound.conf and the voip-
>> > handset.state that comes with milestone5.
>> >
>> > Brian's config is available at:
>> >
>> Thanks for the precious hints guys. I am running shr unstable and linphone
>> 3 there eats up to 80% of cpu time and so makes a conversation impossible.
>> Did u do the same experience there?
> Conversation was no problem for me, so I didn't even look at CPU load. It will
> depend on the codec used, so you may have been using a computationally heavy
> one. Another factor could be enabling echo cancellation. I assume it's
> linphone you see using 80% rather than some other app coincidentally hogging
> CPU.
Indeed, it was the enabled echo cancellation! Thanks! But now I have
another problem: the voip-handset.state file allows me to talk,
however I can not hear anything. The only statefile I can use to hear
sound from my internal speaker is the stereoout.state file. I tried
also using the voip-handset.state file I had from my previous
OM2008.12 linphone2 installation but it doesnt change anything. Did I
forget to set something? My linphone devices are all set to
ALSA:default device (thanks to your asound.conf)

More information about the community mailing list