Fwd: unable to get the boot menu

Bram Mertens mertensb.mazda at gmail.com
Tue Mar 3 00:31:54 CET 2009

(Replied to Joel instead of list by mistake)
---------- Forwarded message ----------
From: Bram Mertens <mertensb.mazda at gmail.com>
Date: Tue, Mar 3, 2009 at 12:30 AM
Subject: Re: unable to get the boot menu
To: Joel Newkirk <freerunner at newkirk.us>

On Mon, Mar 2, 2009 at 10:25 PM, Joel Newkirk <freerunner at newkirk.us> wrote:
> On Mon, 2 Mar 2009 20:56:59 +0100
> Bram Mertens <mertensb.mazda at gmail.com> wrote:
>> So now I have what I believe to be everything I need on the SD but I'm
>> unable to boot it!
>> I've tried several times to follow the instructions on
>> http://wiki.openmoko.org/wiki/Booting_the_Neo_FreeRunner as well as
>> those on http://wiki.openmoko.org/wiki/Bootloader but I cannot get the
>> device to display the boot menu.
>> From the above I understand that the following should suffice:
>> 1) shut down the device and disconnect it from the computer
>> 2) remove the battery for at least 30 secs
>> 3) press and hold the AUX button
>> 4) press and hold the power button until the boot menu appears
>> The first thing I see is "OpenMoko", then the initialization messages
>> scroll by and FDOM is started.  (The AUX button flashes once shortly
>> before "Openmoko" is displayed on the screen.)
> Just to clarify and be sure:
> 3) Press and hold down AUX button
> 4) while AUX is still held down, press and hold power button until the
> boot menu appears.  Then release both buttons.
> That should present you with the NOR boot menu.  The NAND boot menu
> (the one that can be readily overwritten) is accessed by:
> 3) Press and hold down Power button
> 4) while holding down power button, and /before/ booting begins (IE,
> within 5-6 seconds should be fine) press and hold AUX, then release both
> buttons after boot menu appears.
> I've never found the powerdown process to be so sensitive...  The issue
> with external power (step #1 refers to AC power as well as USB-port from
> a host computer) is that when you plug in, it often starts booting
> without needing a power press.  In this situation, however, if you're
> holding down the AUX button when you plug it in you'll end up with the
> boot menu.  Other than removing the battery to effect a hard-reset, I've
> never performed step #2 above.
> Generally you'd want the NAND boot menu to actually boot, since it's
> presumably at least as new as the NOR, but potentially much newer,
> possibly drastically different (Qi vs uBoot).  Use the NOR boot menu
> when flashing, however.
> j

I've tried several times again.

After removing the battery for several minutes the device
automatically boots when the battery is replaced.  By the time I've
turned the device around after replacing the back cover the "openmoko"
logo is already displayed.  (The device was not connected to any

So I've shut the device down again by pressing the power button for
several seconds.

Without removing the battery but waiting some 30 seconds:
1) press and hold AUX
2) press and hold power
after about 4 seconds the AUX button lights up, about 2 seconds later
the "openmoko" logo is displayed and after that the device boots
I released both buttons as soon as the "openmoko" logo was displayed.

Again power down the device
1) press and hold power
2) press (and hold) AUX approx 2 seconds after pressing power before
the openmoko logo is displayed

again the device boots without displaying any kind of boot menu

Is it possible to reconfigure the wait time of the boot menu via the
device?  I can't find anything in the settings menu or any terminal
application that would allow me to execute commands.



More information about the community mailing list