Language of hardware keyboard

Helge Hafting helge.hafting at
Wed Mar 4 12:24:25 CET 2009

Leonti Bielski wrote:
> Hello!
> Yesterday I tried to connect my hardware keyboard to Freerunner.
> I'm using SHR - testing and I used [1] to make it work.
> But the language of the keyboard is English. How do I change that?

There are at least two ways:

1. Select a proper keyboard in /etc/X11/xorg.conf

the file shoukld have a section like this for a Norwegian keyboard. For 
another language, replace "no" with whatever you need.

Section "InputDevice"
     Identifier     "Generic Keyboard"
     Driver         "kbd"
     Option         "CoreKeyboard"
     Option         "XkbRules" "xorg"
     Option         "XkbModel" "pc105"
     Option         "XkbLayout" "no"

However, the FR ships without a xorg.conf file. So some experimentation 
is needed to see if it honors the file, and if you need to install extra 
keyboard files that not necessarily comes with the device.

2. Remap the keyboard using xmodmap
The FR ships with xmodmap, so you can write a script that uses several 
xmodmap commands, one per key that differ from english layout. Then 
arrange so the script is executed whenever X starts on your freerunner.

Helge Hafting

More information about the community mailing list