SHR testing and TangoGPS problem

Joel Newkirk freerunner at
Fri Mar 6 04:50:20 CET 2009

On Thu, 5 Mar 2009 14:48:49 -0500
Adam Jimerson <vendion at> wrote:

> I tried to upgrad TangoGPS one my SHR testing install because it
> didn't seem like it was working, and fso-gpsd said that it was
> running, but when I tried to do it even with -force-depens it removed
> the version the SHR testing came with and gave me this error:
> root at om-gta02 ~ $ opkg -force-depends install libsqlite3-0
> libpixman-1-0 libgl
>  ib-2.0-0
> us-glib-1-2 libdbus-1-3 libcurl4 libcairo2
> nmoko/tangogps_0.9.6-r0_armv4t.ipk

>  Collected errors:
>  * Warning: Cannot satisfy the following dependencies for tangogps:
>  * gtk+-fastscaling (>= 2.10.14) *
> Do I need to install a older version of tangogps inorder to get it to
> work?

You should be good to go.  What you got was a warning instead of an
error regarding gtk+-fastscaling - exactly what you asked for with the
"-force-depends", which makes dependency errors into warnings instead.

That said, you may have believed it not installed if the icon didn't
appear - if that's the case then
edit /usr/share/applications/tangogps.desktop and try changing the
"application" category to "applications".

BTW - a quick search of wiki or list archives should turn up this
answer, keywords like "tangogps" and "fastscaling"... ;)


More information about the community mailing list