date and GPS related questions

Daniel Willmann daniel at
Sun Mar 15 13:34:14 CET 2009


On Thu, 12 Mar 2009 22:19:05 +0100
Fernando Martins <fernando at> wrote:

> 1) I got the date reset to 1970 a few times. I was not paying
> attention but I guess this happens when battery is removed, i.e.,
> there's no battery specific for the clock?

there is a backup battery, but in my experience it only takes a couple
hours without battery until the time is lost again.

> 2) Several posts mentioned that GPS could only get the fix if date
> was correct, the requirements being within 1 sec precision. However,
> with the date/time completely messed up, GPS is getting the fix
> anyway (and it's fairly fast, 1 min or so). So, what's up? I'm using
> SHR unstable from January. Is the GPS driver (?) being to ignore
> dates before FR production, or something else?

It's not ignoring anything, but the chip is robust enough to recover
from that. ogpsd should add some safeguards like storing the offset GPS
time/system time so that it will report the correct time to the GPS
chip even if somebody sets their time to be five minutes ahead

> 3) While using tangoGPS and I enter a building, when I come out, a
> fix is not gotten until I reboot FR. Is this a known issue?  any
> quicker workaround than rebooting?

So you're going in with a fix and when you come out you wont get a fix
any more? How long are you staying in the building? Please check with
the GPS tabs in zhone How many SVs have ephemeris before and after you
are inside the building. Also check after you've left the building if
you are seeing any signals from SVs and if the chip actually thinks
there are SVs in the sky.

Daniel Willmann
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
Url : 

More information about the community mailing list