[QT Extended Improved] on debian rootfs with 2.6.28

Franky Van Liedekerke liedekef at telenet.be
Mon Mar 30 00:30:49 CEST 2009

On Mon, 30 Mar 2009 00:17:42 +0200
Radek Polak <psonek2 at seznam.cz> wrote:

> Hi,
> i am now working on QTE running on debian rootfs with
> recent kernel (latest andy-tracking).
> Right now i think i have working all that i was using
> with QTE 4.4.3 from here [1]. This basically is:
> * working SMS/calls
> * GPRS
> * suspend/resume
> Attached are patches that i used and work-in progress
> howto. I will upload whole rootfs during this week.
> As for the patches - 0001 is taken from here [2] and
> adjusted to apply to current git.
> 0002 fixes problem when alsa scenarios are being
> loaded from /etc/alsa which make troubles for debian
> rootfs where this dir is used for something else. It
> uses just /usr/share/openmoko/scenarios/ which is now
> standard location for all distros.
> 0003 handles renaming of PMU input events
> 0005 gets rid of apm in favour of sysfs for suspending
> All those patches should not break 2.6.24 compatibility
> so maybe it makes sense to apply them to QTE improved?
> Cheers
> Radek
> [1] http://dashi-x02.karadog.net/~lihouyu/qtextended/4.4.3/
> [2] http://pastebin.com/m4cf5bb93


does your version unsuspends ok for sms's as well? Mine doesn't for
now, but the current recommended kernel is
testing-om-gta02-20090120.uImage.bin, and maybe that one is the source
of those problems ...
Also, given the fact that Houyu Li doesn't seem to be there, I think we
need to change the git-location, since nobody has access ... at least
these fixes should get in (and also the lan-network script update, and
the fix for alarms and unsuspending).


More information about the community mailing list