[Om2009] testing Release 3

Hans Zimmerman hans at everlasting.be
Sun May 10 09:31:04 CEST 2009

Johny Tenfinger wrote:
> On Sat, May 9, 2009 at 22:18, Hans Zimmerman <hans at everlasting.be> wrote:>
>> My update sequence showed some errors.
>> Actions executed:
>> opkg remove -force-depends frameworkd paroli
>> opkg update
>> opkg upgrade
>> opkg install frameworkd paroli
>> -> paroli did not install because of conflict with the file
>> /usr/share/elementary/themes/default.edj with elementary-themes
>> opkg remove elementary-themes -recursive
>> opkg install paroli
>> opkg install paroli-autostart paroli-sounds
>> -> paroli did not want to start because of missing dependency
>> opkg install python-elementary
>> -> paroli starts, waiting for someone to call me on saterday night :)
> opkg remove elementary-themes -recursive was really wrong!!! You
> should use -force-depends...

-force-depends makes warnings out of errors regarding dependency checks.
I'm personally against overruling errors. If the systems says there is 
an error there is an error, if it should be a warning, it should say 
it's a warning.

More information about the community mailing list