[SHR-testing] Black Screen of Death?

Bram Mertens mertensb.mazda at gmail.com
Tue May 12 08:06:36 CEST 2009


Yesterday I encountered again what I'd call a Black Screen Of Death.
For a - low quality - picture see
http://users.telenet.be/bmertens/FreeRunner/FreeRunnerBSOD.jpg ).

I've encountered this before but I'm never able to tell what exactly
happened.  Usually I leave the device for some time to find it like
this when I return.  Yesterday the device was on the seat next to me
in the car doing nothing special (no GPS, no audio or anything).  I
had only booted it several minutes before after switching the SIM card
to a card I use for testing and made one phone call.

I'm using SHR-testing from 20090422 on an SD card:
with U-Boot (u-boot-gta02v5-1.3.1+gitrb20cc520a22715fe7ff069b36b7dfdbb925a8e5a-r1.bin)

When I get this black screen with a single white line the only way
I've found to recover is to pull the battery, the device won't respond
to screen touches or even holding the power button.  I have never
tried to ssh into the device.
It usually feels warm but I can't tell if it is a result of this or a
cause.  What is normal operating temperature for the FreeRunner?

Has anybody encountered this?  I haven't been able to find references
to anything similar, unless this too is a variation of the WSOD.

Don't know if it is relevant but over the past couple of days the at
daemon has regularly crashed causing ffalarms to fail.  Other daemons
have failed as well but less frequently.

Thanks in advance


More information about the community mailing list