[Om2009] Suspend not working after recieving a call

Laszlo KREKACS laszlo.krekacs.list at gmail.com
Thu May 14 14:30:42 CEST 2009

>> I don't think there is an existing ticket for that, so feel free to open a
>> new one :) And the interesting logs are /var/log/paroli.log
>> /var/log/frameworkd.log
> i got a nice failure-to-suspend last night, and snagged a copy of everything
> in /var/log before rebooting the 'moko.  if memory serves, it happened after
> an SMS message came in.  i checked the count of paroli windows using the
> illume top bar, and there were not more than two.

I dont think that this "failed to suspend" problem is related to paroli at all.
I think this problem is only frameworkd, and calypso issue.
I verified(?) it, when this problems appears, I initiate the suspend command
through cli-framework, and obviously it fails too:

root at om-gta02:~# cli-framework
usagei  failed to connect to bluez
freesmartphone.org interactive command line
>>> usageiface.Suspend()

And it hangs there for about five minutes.

The relevant logs:
console: http://pastebin.com/m76f069ef
dmesg: http://pastebin.com/m69d4c404
frameworkd(relevant part): http://pastebin.com/m2101c4d5

I also carry the full frameworkd.log, and have one more saved logs
when occured again.

I dont send SMS. I tried once, but was too long (was corrected by
paroli with a nice
popup, and a counter, thx!)

I only use my phone for calling, ie. intiate calls and receive them.
The failed to suspend
problem usually happens when I *receive* the call, and after I talked,
and hang up,
I cant suspend anymore. Note please, this does not happen all the
time, and never
happened the first call after booting. It happens the second, third,
etc received call.
Pretty much random this nasty bug.

I also tried with yesterdays (om2009 unstable) image, the same failure, and
it happens even more often.

This and the massive slowdown of frameworkd[1] prevents me from using
my phone as a
*reliable* day-to-day phone. All the other (paroli) bugs was fixed by
mirko (thx!).

So where to open the proper bugreport? I think we must gather some attention to
be fixed once and for all;)

And what else information should we gather from the phone, when this
problem happens?
Im more than happy to try to assist bughunting!;)

[1]: http://lists.openmoko.org/pipermail/community/2009-May/047921.html

Best regards,

More information about the community mailing list