running google mobile applications?

Juan Lucas Dominguez Rubio jldominguez at
Sun May 17 20:16:38 CEST 2009

This app:
is a midlet (JME-CLDC), so you cannot start it as you would do with a JSE or JME-CDC application.
In this page there are instructions to start a midlet on Phoneme Advanced:
(bottom of page)

Perhaps you can adapt those instructions to your Linux device. Also, unzip that jar file and have a look at the manifest.

Juan Lucas

De: community-bounces at en nombre de Francesc Romà i Frigolé
Enviado el: dom 17/05/2009 18:40
Para: community at
Asunto: running google mobile applications?


I'd like to run the gmail java application in my moko. Has anybody tried that?

I couldn't download the application from the freerunner itself ( woosh, midori and dillo2 all failed) so I found this link and downloaded the .jar with wget:


I don't know much about java but after reading this I figured out I needed to install a java ME, so I added the jailmo repositories as explaned here and then installed phoneME like this:

opkg -force-depends install phoneme-advanced-foundation

but when I try to run the application I get the following errors:

$ cvm -jar gmail-g.jar 
-jar: Could not find Main-Class manifest attribute

Any suggestions?

Another possibility would be to run the new web application "for android and iPhone", but is there any browser for moko that supports HTML5 or gears?

I'm using SHR testing.


-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list