[debian] doom accel/touch not working right?

Fox Mulder Quakeman1 at gmx.net
Tue May 19 00:40:49 CEST 2009


today i tried again opendoom for freerunner from Scott Carlson and it
worked much more than it does a few months earlier. Maybe because i use
xserver-xglamo and not fbdev at the moment.
First i had to modify the /usr/games/dm startscript to [1] and it worked
in landscape mode with a resolution of 240x320. But my first problem was
that the touchscreen "buttons" seems not to work as expected. Only the
menu "button" in the upper right always work. The up/down/enter
"buttons" within the menu only seem to work sometimes. When i touch
everywhere around sometimes one of these buttons seems to be touched.

After a wild touching session i got a new game started but the
accelerometer inputs seems to be broken within doom. I can now touch the
menu und fire button which worked but no matter how i rotate my neo the
player never even moves a bit.

I'm using a recent 2.6.29 kernel from andy-tracking and the
accelerometers work in mokomaze or acceleroids, so they seem to be ok.

I hope Scott you could modify your opendoom version so it works again
with accels? :)

Or maybe someone else know what to change in the sourcecode to get it going.


# Don't turn LCD off
mdbus -s org.freesmartphone.ousaged /org/freesmartphone/Usage \
org.freesmartphone.Usage.SetResourcePolicy 'Display' 'enabled'

# LCD -> QVGA landscape
echo qvga-normal > /sys/bus/spi/devices/spi2.0/state
xrandr -s 240x320 -o 1

# start Doom
/usr/games/opendoom -config ~/.opendoom/opendoom.cfg

# LCD -> VGA normal
echo normal > /sys/bus/spi/devices/spi2.0/state
xrandr -s 480x640 -o 0

# Dim LCD automatically
mdbus -s org.freesmartphone.ousaged /org/freesmartphone/Usage \
org.freesmartphone.Usage.SetResourcePolicy 'Display' 'auto'

More information about the community mailing list