Om2009 testing release 4

Warren Baird wjbaird at
Sun May 24 23:14:01 CEST 2009

I'm afraid my experience with TR4 wasn't that great. I installed it Friday
night, and played with it enough to make sure that I could make and receive
calls.   I must admit that after using QtE it was nice to be able to install
software like a pdf reader and mokomaze.

However, The first real call I got was from my wife heading over to the park
with our daughter.  I heard the ringing, and the phone seemed to wake up
from suspend quickly (which puts it ahead of my experience from OM2008), but
when I pressed the answer button nothing happened.   I had been running
omrotatenew, and I've noticed that it sometimes screws up the touch screen
calibration, so I don't know if this is actually a TR4 problem, or an issue
with the rotation.

However, once I missed the call, I figured I'd use the call log to call her
back, so I went to the call log and clicked on the entry.   It took me to an
empty dialer window - without a number entered.     Since I know her number
I just typed it in, and clicked on the 'call' button.   Nothing happened.
I clicked on the 'back button' - also nothing.   I used the illume menu to
take me to the main paroli windows, but couldn't make anything work there
either.  I ended up rebooting.

After the reboot, I still couldn't get dialing to work, so I rebooted again,
and then was able to call my wife --- total time elapsed to make the call
was probably 20 minutes.   When I did get ahold of her, she said that she
could barely understand me, since the audio was quite distorted - she
sounded fine to me, and probably a bit louder than I get with QtE.

I might give TR4 another try without omreotatenew running and see if it's
any more reliable that way...


On Sun, May 24, 2009 at 5:46 AM, Hans Zimmerman <hans at> wrote:

> Hans Zimmerman wrote:
> > Ben Wong wrote:
> >> Thanks for the update.  Unfortunately Om2009 is still not a usable
> >> phone out of the box for me.  I realize that this is probably my fault
> >> for not persevering, but I will be reverting to SHR since this is my
> >> only phone.
> >>
> >> Here are my issues, in order of importance:
> >>
> >> 1) Horrible audio distortion during calls.  People tell me that I
> >> sound like I'm being played back over a blown-out speaker.  I tried
> >> calling +1800GOOG411 (google's speech recognition phone directory) and
> >> it was unable to understand me.  I bet this is something tweakable
> >> with the ALSA settings, but I'm surprised that Om2009t4 gets the
> >> default wrong when SHR-testing works fine.  I don't know if it's
> >> relevant but I have an A6 model of the Freerunner.
> >>
> >
> > 1) I'm experiencing the same (according to the people I call). I however
> > did not experience this with the previous images (I'll try to flash
> > testing 3 back to see if the problem remains or is gone).
> >
> I went back to the gsmhandset.state which worked for me (so reverted to
> what was changed in The
> contacts I called so far said they could understand me way better, I was
> no longer "breaking up".
> Hans
> _______________________________________________
> Openmoko community mailing list
> community at

Warren Baird - Photographer and Digital Artist
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list