[debian] doom accel/touch not working right?

Fox Mulder Quakeman1 at gmx.net
Thu May 28 13:32:20 CEST 2009

Fox Mulder wrote:
> Hi,
> today i tried again opendoom for freerunner from Scott Carlson and it
> worked much more than it does a few months earlier. Maybe because i use
> xserver-xglamo and not fbdev at the moment.
> First i had to modify the /usr/games/dm startscript to [1] and it worked
> in landscape mode with a resolution of 240x320. But my first problem was
> that the touchscreen "buttons" seems not to work as expected. Only the
> menu "button" in the upper right always work. The up/down/enter
> "buttons" within the menu only seem to work sometimes. When i touch
> everywhere around sometimes one of these buttons seems to be touched.
> After a wild touching session i got a new game started but the
> accelerometer inputs seems to be broken within doom. I can now touch the
> menu und fire button which worked but no matter how i rotate my neo the
> player never even moves a bit.
> I'm using a recent 2.6.29 kernel from andy-tracking and the
> accelerometers work in mokomaze or acceleroids, so they seem to be ok.
> I hope Scott you could modify your opendoom version so it works again
> with accels? :)
> Or maybe someone else know what to change in the sourcecode to get it going.

No one knows how to fix the bug that the input isn't working right anymore?

When i do a "hexdump /dev/input/event2" or with event3 i got data so the
accels seems to work. A short look at the modifications Scott made to
the sourcecode shows that he uses these input devices. But ingame the
accels has no effect at all.
I also took a short look at the touchscreen modifications in the
sourcecode but i'm no C(++) programmer so i can't say what could be wrong.


More information about the community mailing list