Navit - german localization causes rounding of GPS-position

Fox Mulder Quakeman1 at
Sun Nov 1 14:10:47 CET 2009

David Garabana Barro wrote:
> O Sábado, 31 de Outubro de 2009, Christian Rüb escribiu:
>> Hi,
>> I had the same problem. Also bookmarks will be saved using comma instead of
>>  dot a separator (locale settings). As a workaround I unset LC_ALL before
>>  starting navit (i.e. "Exec=unset LC_ALL; navit" in
>>  /usr/share/applications/navit.desktop). That way your LANG variable keeps
>>  set to de_DE.UTF-8, but locale settings are not in German...
>> I posted this in navit ML back in July - but no response if this is
>>  intended or a bug :(
> At least is't sure it's a known bug/feature:
> http://wiki.navit-

I also use LANG="de_DE.UTF-8" and got the wrong position in navit but i
haven't set LC_ALL. So what settings/vars should i change to get navit
working in german and with correct position? :)


More information about the community mailing list