No gps connection in navit with SHR-unstable

Fox Mulder Quakeman1 at
Thu Nov 26 00:25:11 CET 2009

Martin Jansa wrote:
> On Wed, Nov 25, 2009 at 11:44:13PM +0100, Fox Mulder wrote:
>> Tanogps uses gpsd, so this could not be the problem.
>> But now i tried by accident (opkg update downgraded navit r2797 to shr-u
>> version r2735) the navit version in the shr repository (r2735) and this
>> version works and connects to the gps without problems. I also can see
>> my correct position on the map. So it seems that the precompiled
>> binaries from the navit homepage for the openmoko are not compatible
>> with current shr-u. Tomorrow i will try to contact someone from the
>> navit projects and say this so maybe we can find out where the problem
>> lies. Because i like to have the newest one and not the one from the
>> shr-u repository. :)
> Are you sure its because gpsd?
No, i was only saying, that (fso-)gpsd is working right because tangogps
also uses gpsd and it works.

> svnrevs > 2760 have this problem 
> try with navit.xml config if you're using modified one
I used the navit.xml from r2797 so this was not the problem. Right after
start in the console navit shows this gps.h incompatibility error mesage
befor it starts. So i think that the navit package from the navit
homepage are compiled with another version of some lib which is not
compatible with shr-u.


More information about the community mailing list