No wireless in Debian Sid

Al Johnson openmoko at
Tue Oct 6 14:44:06 CEST 2009

On Monday 05 October 2009, Esteban Monge wrote:
> Hello Again...
> I found this command, I think is the correct way to enable the wireless:
> mdbus -s org.freesmartphone.odeviced
> /org/freesmartphone/Device/PowerControl/WiFi
> org.freesmartphone.Resource.Enable
> And to turn off:
> mdbus -s org.freesmartphone.odeviced
> /org/freesmartphone/Device/PowerControl/WiFi
> org.freesmartphone.Resource.Disable
> I going to make the little gui based in this commands...

You should not use this interface! From the docs[1]:
"Applications usually are not allowed to use this interface directly, they 
will solely interact using the org.freesmartphone.Usage API."

The Resource Handling introduction[2] describes how you're supposed to control 
resources. In short you should be using:

mdbus -s org.freesmartphone.ousaged /org/freesmartphone/Usage 
org.freesmartphone.Usage.SetResourcePolicy WiFi enabled

The valid states are enabled, disabled and auto, with auto being the default. 
Auto will enable the resource only when at least one application has requested 


More information about the community mailing list