Tips when GSM doesn't work

Gmail foringer at
Tue Oct 13 07:25:57 CEST 2009


I'm having this issue periodicaly. My suggession for this problem is to
reinstall some packages with a magic command:

opkg install -force-reinstall libgsm0710mux0 libfsotransport0 \
         libfsoframework0 libfsobasics0 fso-abyss fsousaged \
        libgsm0710mux-config frameworkd frameworkd-config-shr \
        libframeworkd-phonegui-efl0 \
        shr-contacts shr-messages shr-dialer ophonekitd

And after reboot GSM works fine for several days or weeks :)

В Втр, 13/10/2009 в 13:19 +1100, Alex (Maxious) Sadleir пишет:

> 2009/10/13 Cristian Gómez <cristianpark at>:
> > I'm using my FR (with SHR - last) as main phone. I experienced sometimes
> > that when I start SHR, GSM functions doesn't start
> > I don't know how can I check any log or how can I start manually GSM
> > services, I type /etc/init.d/frameworkd restart, but I don't know if it's
> > supossed to solve this issue. Can you give me some advices to take in count
> > when I have this problem?
> I've had this when the sim card isn't fully pushed into the slot
> (contacts between phone and card aren't quite aligned) but you can
> still lock it (or it feels like you lock it). I think mickeyterm
> returns CME ERROR 3 on many SIM requests when this happens but it
> might just do that anytime the GSM module is confused.
> > so I power down by removing the battery (I know, the ugly way) and wait a
> > few seconds to put it back again. When I power on the FR again, when SHR
> > starts, I don't have GSM services
> Happens when you do ugly things like that ;) You can also get further
> trouble because the FR is designed such that a correctly aligned SIM
> card pushes down the SD card.
> _______________________________________________
> Openmoko community mailing list
> community at
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list