[debian] unexpected troubles

Neil Jerram neiljerram at googlemail.com
Tue Oct 13 22:25:51 CEST 2009

2009/10/13 Joshua Judson Rosen <rozzin at geekspace.com>:
> Neil Jerram <neiljerram at googlemail.com> writes:
>> I've just installed Debian again, and am surprised to be experiencing
>> some low-level problems.  Hopefully they are easily fixable.
> I'll try addressing the issues that I can:

Many thanks for your reply.

>> - Load average unreasonably high.  Right now, for example, my top says
>> "load average: 8.11, 8.13, 8.09".  Yet CPU usage is only reaching
>> around 6%.
> Do you perhaps have a bunch of processes waiting on disk I/O? Maybe
> waiting to be paged-in from swap? How many processes are in
> uninterruptible sleep (`D') state? These also contribute to the
> load-counts, in Linux.

Thanks, I didn't know that.  I followed up on the D state, and found
that it usually indicates a kernel or device driver problem.  Based on
that, and the facts that I had to shutdown several times by pulling
the battery out, and that the way I installed Debian wasn't completely
vanilla (I tried to install into an existing partition), I decided
that it would probably be a good idea to reinstall from scratch, and
I've now done that.

> What does vmstat say (I usually run "vmstat 2")?
> What are your top memory-consuming processes (in terms of both real
> and virtual memory footprint)?

I'm afraid I didn't check these before reinstalling.

> Do you have a swap partition (or file)? Are you running from the
> internal NAND flash, or a micro-SD card?

I was running from the first partition of a micro-SD card.  No swap
partition, but post-installation I had prepared a 200Mb swap file on
/dev/mmcblk0p2.  I hadn't added a mount and swapon for this to
/etc/rc.local, so it wasn't being used during the boot.  I did the
mount and swapon later - I think after I'd already tried starting
Emacs, and that had hung - and it didn't appear to make any difference
(apart from top reporting the available swap).

>> - Battery not apparently charging.  I'm using the USB lead from
>> another Linux computer, which successfully charges OM2009/Paroli and
>> SHR.  But with Debian there is no + on the battery icon, and no orange
>> (or blue) light behind the power button.
> There's mention of issues with APM on the DebianOnFreeRunner Debian
> Wiki page:
>     http://wiki.debian.org/DebianOnFreeRunner#KnownProblems

That looks like a red herring / misunderstanding to me.  IIUC, it was
resolved some months ago by an apm-emulation script that calls the
dbus API.

Post-reinstall, openmoko-panel-plugin is showing a believable battery
status, and responds to plugging in the USB cable, and I'm pretty sure
that it did that for a while after my first install too. So I guess I
must have broken it by one of my first install experiments.

>> - ssh (via USB) not working.  The desktop end looks fine:

Similar situation here.  Post-reinstall, working fine.

So, right now I've reinstalled from scratch, with
./install.sh all

My problem now is no GSM - which was also the case after my previous
install - with the symptoms being that
- Zhone briefly says "Usage: Requested resource GSM with error" (or a
permutation of those words)
- Zhone's phone, messages and contacts buttons stay greyed out.

I've rebooted twice since reinstallation, so it isn't a first-boot problem.

GSM works fine on OM2009/Paroli (in NAND), so it isn't a SIM-seating problem.

I don't have a PIN, so it isn't a PIN entry problem.

Any ideas?

I wonder if I've got all the packages installed that I should have:

debian-gta02:~# dpkg -l *fso*
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version        Description
un  fso-abyss      <none>         (no description available)
un  fso-config     <none>         (no description available)
ii  fso-config-gta 20090224-1     configuration files for Openmoko GTA02 Neo F
ii  fso-frameworkd freesmartphone.org Framework Daemon
un  fso-frameworkd <none>         (no description available)
ii  fso-gpsd       0.8-3          gpsd compatibility daemon for the freesmarpt
ii  fso-gsm0710mux      GSM 07.10 Multiplexer
un  fso-sounds     <none>         (no description available)
ii  fso-sounds-yue 20081031-2     Yue base ringtones for the freesmartphone.or
un  fso-sounds-yue <none>         (no description available)
un  fso-usaged     <none>         (no description available)
ii  fso-utils      0.git20090919. Useful tools for the freesmartphone.org syst
ii  pkg-fso-keyrin 2009.09.12     GnuPG archive key of the pkg-fso Debian repo

debian-gta02:~# dpkg -l *one*
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version        Description
ii  libphone-utils 0.1+git2009080 library for basic phone operations
un  oneko          <none>         (no description available)
ii  python-phoneut 0.1+git2009080 python bindings for libphone-utils
ii  zhone          0-git20090610- freesmartphone.org demo GUI
ii  zhone-illume-g 0-git20090610- freesmartphone.org demo GUI - Illume interac
un  zhone-session  <none>         (no description available)

In particular I've been hearing recently about fso-usaged, fso-abyss
and ophonekitd, and none of these is installed.  Is that a problem?


More information about the community mailing list