[QtMoko] Running applications thrue ssh

Matthias Apitz guru at unixarea.de
Thu Oct 22 09:15:05 CEST 2009

El día Thursday, October 22, 2009 a las 10:56:30AM +0400, Gmail escribió:

> Hello list!
> I have a problem running any application thru ssh.
> I run this set of commands:
> $ ssh -X root at moko
> neo:~# source /opt/qtmoko/qpe.env
> neo:/root# export DISPLAY=localhost:10
> But when I run any application in /opt/qtmoko/bin, I'm getting an output
> to the FR screen. Is there any any possibility to get output to the
> desktop screen?

You should not set $DISPLAY when using -X in ssh, the sshd will set it
for you correctly:

$ ssh -X root at moko
Warning: untrusted X11 forwarding setup failed: xauth key data not generated
Warning: No xauth data; using fake authentication data for X11 forwarding.
root at om-gta02:~# echo $DISPLAY
root at om-gta02:~# xterm
Warning: locale not supported by Xlib, locale set to C
Warning: X locale modifiers not supported, using default
Failed to open input method

and the xterm window comes up on my FreeBSD desktop;



Matthias Apitz
t +49-89-61308 351 - f +49-89-61308 399 - m +49-170-4527211
e <guru at unixarea.de> - w http://www.unixarea.de/
Vote NO to EU The Lisbon Treaty: http://www.no-means-no.eu

More information about the community mailing list