[WikiReader] can we edit the WikiReader wiki?

Christopher Hall hsw at openmoko.com
Fri Oct 23 04:14:13 CEST 2009

On Thu, 22 Oct 2009 16:20:39 -0700
Doug Jones <dj6mf at frombob.to> wrote:

> I clicked that Edit button, but it seems to want money from me.  :-)

Did you create an account on github, I think the free account should

> But I assume that somebody else here can edit this page:
> http://wiki.github.com/wikireader/wikireader/building-from-source
> In addition to the dependencies listed there, I also had to install 
> gforth, qt4-qmake, and g++.

 I can, I added the packages I use.
(these are listed in doc/Using-schroot for Ubuntu jaunty_i386)

> After installing those, I got as far as:
> g++ -c -pipe -O2 -D_REENTRANT -Wall -W -DQT_NO_DEBUG -DQT_GUI_LIB 
> -DQT_CORE_LIB -I/usr/share/qt4/mkspecs/linux-g++ -I. 
> -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4 
> -I../../../wiki-app -I../../../samo-lib/include 
> -I../../../samo-lib/drivers/include -I../../..//samo-lib/minilzo/ 
> -I../../../samo-lib/lzma -I../../../samo-lib/fatfs/src 
> -I../../../samo-lib/fatfs/config/c33/read-write -I. -I. -o main.o
> main.cpp main.cpp:21:17: error: QtGui: No such file or directory

maybe you are missing libqt4-dev

Best regards.
Christopher Hall                      hswATopenmoko.com

More information about the community mailing list