[SHR-U] opkg displays some packages twice

Jens Seidel jensseidel at users.sf.net
Sat Oct 24 14:11:13 CEST 2009


I have some opkg issues recently.

root at om-gta02:~# opkg list | grep opkg
libopkg-dev - 0.1.6+svnr215-r4 - Opkg Package Manager
libopkg0 - 0.1.6+svnr215-r4 - Opkg Package Manager Library
libopkg0 - 0.1.6+svnr215-r2 - 
opkg - 0.1.6+svnr215-r4 - Opkg Package Manager
opkg - 0.1.6+svnr215-r2 - 
opkg-collateral - 1.0-r1 - opkg configuration files
opkg-collateral-dbg - 1.0-r1 - opkg configuration files
opkg-collateral-dev - 1.0-r1 - opkg configuration files
opkg-dbg - 0.1.6+svnr215-r4 - Opkg Package Manager
opkg-dev - 0.1.6+svnr215-r4 - Opkg Package Manager

As you can see opkg reports that e.g. opkg is installed twice. Also
list_upgradable marks this package upgradeable:

root at om-gta02:~# opkg list_upgradable | grep opkg
libopkg0 - 0.1.6+svnr215-r2 - 0.1.6+svnr215-r4
opkg - 0.1.6+svnr215-r2 - 0.1.6+svnr215-r4

The problem arised once I followed
and tried to manually update libfso-glib0 to be able to upgrade
fsousaged. I temporarily removed all packages depending on libfso-glib0
and I'm no longer able to install them again:

root at om-gta02:~# opkg install tangogps
Installing tangogps (0.9.6-r1) to root...
Collected errors:
 * ERROR: Cannot satisfy the following dependencies for tangogps:
         *  libfso-glib0 (>= 0.2.1+gitr47+7608c8d98bb65bb5beca6621eb86920b71df1bc9) * 

Any hints? (No upgrading libfso-glib0 does not help as I would get similar
errors mentioning that libfso-glib0 0.2.0 is not installed.)


More information about the community mailing list