QTMoko - Diffuculty trying to mount sd as USB

swoody swoody at ubuntu.com
Thu Apr 15 01:49:57 CEST 2010

Well, I've been trying my darnedest to get the sd card in my phone to
mount as a USB drive. I have been Googling and trying to use this guide
from the wiki to no avail:

When I try to mount the /media/card I get an error that it's not found.
Fair enough, I run 'fdisk -l' and the only information listed is my
internal drive. I was able to see that the device is recognized by my

[ 1959.576070] usb 4-2: new full speed USB device using uhci_hcd and
address 3
[ 1959.791253] usb 4-2: configuration #1 chosen from 2 choices
[ 1959.800462] eth2: register 'cdc_ether' at usb-0000:00:1d.2-2, CDC
Ethernet Device, 00:1f:11:01:13:f6

The next step, I then run 'rmmod g_ether', that module isn't existent. So
through dmesg I find the driver which is active, and I tried disabling
that: "rmmod cdc_ether" This is the only command which didn't give me an
error message.

On the last command (modprobe g_file_storage file=/dev/mmcblk0 stall=0), I
get the output:
FATAL: Error inserting g_file_storage
Unknown symbol in module, or unknown parameter (see dmesg)
After checking dmesg again, I now see:
[ 1830.381547] g_file_storage gadget-lun0: unable to open backing file:

I'm nearly at my wits end here. I don't have access to a card reader, and
I tried setting up 3 different phones (non-FR's) as USB drives, but each
one has it's own unique issue. So I'm left hoping someone out there may be
able to help me out with this. I would really appreciate any ideas you all
may have. Thanks in advance!

- Woody

More information about the community mailing list