QTMoko - Diffuculty trying to mount sd as USB

swoody swoody at ubuntu.com
Thu Apr 15 05:27:48 CEST 2010

> On Wed, 2010-04-14 at 18:49 -0500, swoody wrote:
>> Well, I've been trying my darnedest to get the sd card in my phone to
>> mount as a USB drive. I have been Googling and trying to use this guide
>> from the wiki to no avail:
>> http://wiki.openmoko.org/wiki/Using_the_Neo_as_an_USB_Mass_storage_device
>> When I try to mount the /media/card I get an error that it's not found.
>> Fair enough, I run 'fdisk -l' and the only information listed is my
>> internal drive. I was able to see that the device is recognized by my
>> computer:
>> [ 1959.576070] usb 4-2: new full speed USB device using uhci_hcd and
>> address 3
>> [ 1959.791253] usb 4-2: configuration #1 chosen from 2 choices
>> [ 1959.800462] eth2: register 'cdc_ether' at usb-0000:00:1d.2-2, CDC
>> Ethernet Device, 00:1f:11:01:13:f6
>> The next step, I then run 'rmmod g_ether', that module isn't existent.
>> So
>> through dmesg I find the driver which is active, and I tried disabling
>> that: "rmmod cdc_ether" This is the only command which didn't give me an
>> error message.
>> On the last command (modprobe g_file_storage file=/dev/mmcblk0 stall=0),
>> I
>> get the output:
>> FATAL: Error inserting g_file_storage
>> (/lib/modules/2.6.32-21-generic/kernel/drivers/usb/gadget/g_file_storage.ko):
>> Unknown symbol in module, or unknown parameter (see dmesg)
>> After checking dmesg again, I now see:
>> [ 1830.381547] g_file_storage gadget-lun0: unable to open backing file:
>> /dev/mmcblk0
>> I'm nearly at my wits end here. I don't have access to a card reader,
>> and
>> I tried setting up 3 different phones (non-FR's) as USB drives, but each
>> one has it's own unique issue. So I'm left hoping someone out there may
>> be
>> able to help me out with this. I would really appreciate any ideas you
>> all
>> may have. Thanks in advance!
>> - Woody
> It looks like a kernel/module problem from the name of the kernel I'll
> assume you compiled yourself. Did you copy new modules over when you
> did? I have never had luck with 2.6.32 and mass storage mode. Try it
> with 2.6.29. other tips, if you have a swap partition on SD make sure
> it's off. Make sure your distro is on NAND and not on SD (I think there
> is a way to make it work from SD but so far I've only used
> g_file_storage from a distro on nand). Failing that, try older versions
> of qtmoko kernel (assuming you're on qtmoko and remember to use the
> appropriate modules).
> Assuming all that fails, use latest shr-testing, I know for a fact it
> works on this. If it doesn't work with shr-testing you're doing
> something wrong.

I still couldn't get it to work with an older version of QTMoko, so I
installed shr-testing on the nand, and it worked beautifully. I think I'm
going to keep shr on the phone, and then install QTMoko onto the sd card
afterall. Thanks again for the nudge in the right direction :)

- Woody

More information about the community mailing list