[shr-t] Big update, safe or not ?

Xavier Cremaschi omega.xavier at gmail.com
Fri Apr 23 09:55:40 CEST 2010

Le 18/03/2010 17:23, Sander van Grieken a écrit :
> On Thursday 18 March 2010 17:17:21 Martin Jansa wrote:
>> On Thu, Mar 18, 2010 at 05:14:08PM +0100, Sander van Grieken wrote:
>>> On Thursday 18 March 2010 15:34:42 neo at el-hennig.de wrote:
>>>>   >  But today I've tried an 'opkg update' and now I see :
>>>>> $opkg list-upgradable | wc -l
>>>>> 682
>>>>> Will such a big upgrade be ok or do I have to wait until Sunday (more
>>>>> time to fix borken things) ?
>>>> You should consider to upgrade in more than one step, as space in /tmp
>>>> is limited.
>>> Or simply create a tempdir on the SD card and upgrade using
>>> opkg -t /media/card/tmp upgrade
>> or permanentrly update tmp_dir option in /etc/opkg/opkg.conf for better
>> location if default /var/lib/opkg/tmp doesn't suit you
> Solutions above in increasing level of convenience :)

So I did my upgrade yesterday (720 packages) and it went fine.

Changing tmp_dir option in /etc/opkg/opkg.conf was mandatory because tmp 
files during this update were ~100mo.

My contacts were ok because my SIM has always been empty and my contacts 
were already in opimdb.

I had to install myself fso-gpsd (for tangogps), I think opkg 
uninstalled it (tangogps worked before update).

Wifi seems unavailable, but after seeking the ML I found there is a bug 
in FSO MS5 (MS5 is the revision ?) and I had to do :
     echo s3c2440-sdi >/sys/bus/platform/drivers/s3c2440-sdi/unbind
     echo s3c2440-sdi >/sys/bus/platform/drivers/s3c2440-sdi/bind
in order to get eth0 back.
Any way to fix it permanently ?

Everything else work, kudos to SHR team because I did an upgrade from a 
SHR-t dated from early january 2010 and I was (almost) sure such a big 
update would destroy my FR. But it didn't.


More information about the community mailing list