[SHR] X forwarding: export DISPLAY?

W. B. Kranendonk wankelwankel at yahoo.com
Tue Aug 17 16:47:58 CEST 2010

--- On Tue, 8/17/10, Gerald A <geraldablists at gmail.com> wrote:
(an elaborate help on asking help, as below)
Thanks Gerald for your extensive suggestions! I think my problem is solved, but for the record I'll update my problem description.

> One thing would be more information in your problem report. I think you 
> are trying to start an X client on your FR and have the output come to 
> your desktop, but that isn't 100% clear. Always describe what you are 
> trying to do, in simple terms (eg: "I'd like to start xmines on my FR 
> and have it show up on my Desktop").
I'm trying to configure claws mail, but the resolution of the FR is too low to see where I make a mistake. If I could export it to my laptop, I can see what I am typing. 

> Next, I'm unclear how you are connecting between your FR and your 
> Desktop. USB cable? Ethernet? Intervening device(s)? Wifi? Mind meld? :)
Without actually using different connections as a way of troubleshoot, I have in the meantime tried it over GPRS, Wifi and a direct USB connection (Wifi and USB with two laptops each). Each time it was an encrypted connection (using ssh -Y or ssh -X from the laptop to the phone).

> You reference "DISPLAY", and even give us a pretty good error message. 
> But without some of the above info, it'll be harder to know what is 
> going on.
I see that now.

> It would also help if you let us know your approx. skill level. 
> (eg: "While I'm a Ubuntu GUI guru, I'm a newbie at getting X working 
> between different machines").
Both are about average I guess (mostly while in my direct surroundings there's noone to compare to).

> Now, I have the older 1973 (pre-FR), and it's been a while since I 
> hacked on it. But if memory serves, I was able to get X working with the 
> right settings.
I used to have it running fine, quite a while ago. (My memory does serve so far, but does not have any date (or year, for that matter) related to it.)

> I'll assume a few things -- that you are directly connecting to the FR 
> (no other devices in the middle), and that there is no encryption. In 
> that case, you probably need 2 things. First, is the correct DISPLAY 
> setting. This is usually "DISPLAY=hostname:0.0", where hostname = 
> desktop's hostname. Second, you have to either "xhost" or "xauth" your 
> FR, something like "xhost +freerunnerhostname". Now, I don't know if 
> there is some FR specific issue or distro problem that
> might be affecting the FR/FR OS, so your mileage may vary. But, feel 
> free to try out the above suggestion and let us know if it works, and if 
> it doesn't, please answer some of the other questions above.
I think it turned out (see Dirk's mail) that the default settings in SHR are no X forwarding for sshd.

> Hope this helps,
It does, in some sort of meta-manner. If you can spare the time, would the "updated" problem definition provide enough information or should it contain something else? My current problem is solved, but it might help me describe another in the future.

Thanks again!



More information about the community mailing list