[SHR] X forwarding: export DISPLAY?

Gerald A geraldablists at gmail.com
Tue Aug 17 17:32:06 CEST 2010


On Tue, Aug 17, 2010 at 10:47 AM, W. B. Kranendonk
<wankelwankel at yahoo.com>wrote:

> Without actually using different connections as a way of troubleshoot, I
> have in the meantime tried it over GPRS, Wifi and a direct USB connection
> (Wifi and USB with two laptops each). Each time it was an encrypted
> connection (using ssh -Y or ssh -X from the laptop to the phone).

Just from my experience, I'd go from the "easiest" to the "hardest" to
troubleshoot, so: USB -> wifi ->GPRS. Get the "easy" one
to work, then you can be assured it's not a configuration or other issue
with the more difficult ones.

I think it turned out (see Dirk's mail) that the default settings in SHR are
> no X forwarding for sshd.

Glad to hear that! :)

> > Hope this helps,
> It does, in some sort of meta-manner. If you can spare the time, would the
> "updated" problem definition provide enough information or should it contain
> something else? My current problem is solved, but it might help me describe
> another in the future.

I think the biggest helpful piece of info was that you were trying to use
ssh x-forwarding. Other things that would assist are version #'s of the
various software pieces (although they didn't play a factor in this case).

One thing, which you've already done, is to explain what the underlying
issue and solution was. This way, people who are looking through the
archives can see what worked for you.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20100817/01f461db/attachment.htm 

More information about the community mailing list