Unable to boot with u-boot_glamo242.udfu

giacomo 'giotti' mariani giacomomariani at yahoo.it
Thu Aug 19 17:06:50 CEST 2010

Hello everyone,
I'm trying to test the 242 u-boot boot-loader as suggested in a previous 
At first I tried to flash it using the following commands:

#flash_eraseall /dev/mtd1
#nandwrite -p /dev/mtd1 u-boot_glamo242.udfu

but I encountered an mtdparts problem as described in the wiki[2].
Searching around I found a solution[3].
That solution let me unable to boot again (a menu with the correct 
header and a completely useless "boot" voice appeared as I power+aux the 
mobile) until I flashed (this time with dfu-util ;-))  a new version of 
u-boot[4] which worked quite well.
I tried again, again with dfu-util, u-boot_glamo242.udfu, but it still 
didn't work.

What I noticed:
-my u-boot_env (/dev/mtd2) was quite reach of options (there were 10 of 
-the tenth was (and is) always represented something like a smile;
-if I edit u-boot_env (both with [5] and [6], which is a wrapper of [5] 
I think) I can't get rid of some duplicated reboot/power off voices and 
of the smile.   

Have you got any suggestion?
Do you know if there is some way to correct the bug discussed in [2] in 
order to improve another wrapper I'm writing[7]?



PS I've added the following entry[8] in the wiki, I hope you can add 
some informations.

Do You Yahoo!?
Poco spazio e tanto spam? Yahoo! Mail ti protegge dallo spam e ti da tanto spazio gratuito per i tuoi file e i messaggi 

More information about the community mailing list