Unable to boot with u-boot_glamo242.udfu

Gennady Kupava gb at bsdmn.com
Thu Aug 19 20:46:36 CEST 2010

Hi, Giacomo.

> At first I tried to flash it using the following commands:

> #flash_eraseall /dev/mtd1
> #nandwrite -p /dev/mtd1 u-boot_glamo242.udfu

As you already understood, nandwrite is highly not recommended, use

As i didn't fall to this pitfall, really can tell exactly how to go out
of it. I am always using any uboot & envedit.pl to change environment
and flash images. I think, this should work from scratch, and should be
easy for anything except android (which has different NAND layout). In
anroid case one should just tune that dynparts to match android layout.

> I tried again, again with dfu-util, u-boot_glamo242.udfu, but it still
> didn't work.

Define 'didn't work' please. Can you reach menu? Can you hear 'click' on
boot? To boot, hold power and then start holding aux, you should hold
aux longer than usual (this seem like some latest-svn uboot bug).

>If I edit u-boot_env (both with [5] and [6], which is a wrapper of [5] 
>I think) I can't get rid of some duplicated reboot/power off voices and 
>of the smile.   

Of course, you should edit environment.in and cut everything what you don't need.
Mine current environment.in is not useful for anyone except me, so i'll not 
prove it (i am using xfs and ramconsole).

> Have you got any suggestion?

If you need a bit more help on topic, we can talk on IRC.


More information about the community mailing list