QtMoko v30; UBIFS; can't boot

Ivan Matveev imatveev13 at nm.ru
Mon Dec 27 03:26:21 CET 2010

To: community at lists.openmoko.org
Subject: Re: QtMoko v30; UBIFS; can't boot
Date: Mon, 27 Dec 2010 03:30:57 +0300
X-Mailer: Sylpheed-Claws 2.6.0 (GTK+ 2.8.20; i486-pc-linux-gnu)
Organization: MoniCar

> Btw, don't know where this is set in qi, but you may try u-boot:
> http://wiki.openmoko.org/wiki/U-boot-gena2x  

Thank you for your replies. I don't want to go back to u-boot.
I think my problem started after I'v installed debian to SD per
instructions found at http://wiki.debian.org/DebianOnFreeRunner with
I'v told the install.sh to configure Qi. Probably that was the mistake.
Now I'm trying to figure out what can be configured wrong. 
I'v read the script... Its long... Can't find anything suspicious.

According to this:
Qi...is mount the "identity" partition and get from there the globally
unique MAC address for the USB over Ethernet function instead of the
random one that is otherwise used (If this doesn't work (like with a
GTA01) you may use kernel-commandline parameters g_ether.dev_addr= and
g_ether.host_addr= for the mac in device and host mode of the usb-ether

bad kernel options can be in "identity" or in u-boot environment

QtMoko v30 booted from SD.

neo:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00200000 00010000 "physmap-flash.0"
mtd1: 00040000 00020000 "qi"
mtd2: 00040000 00020000 "depr-ub-env"
mtd3: 00800000 00020000 "kernel"
mtd4: 000a0000 00020000 "depr"
mtd5: 00040000 00020000 "identity-ext2"
mtd6: 0f6a0000 00020000 "rootfs"

mount -t ext2 /dev/mtdblock5 p1

ls p1
bt  imei  lost+found  sn  usb  wlan

echo 'rootflags=compr=zlib' > p1/append-GTA02

No joy. 
Same result: kernel complains that lzo is not compiled in. 
Maybe it misses some modules? Maybe I shell put them in "identity-ext2"?
Have to research more...

BTW tried Gennadys script to decode u-boot
It complains that crc32 function is not defined.

Can I modify u-boot environment from QtMoko running from SD?

More information about the community mailing list