QtMoko v30; UBIFS; can't boot

Gennady Kupava gb at bsdmn.com
Mon Dec 27 06:33:09 CET 2010


> I don't want to go back to u-boot.

I disagree - going to Qi is going back, going to u-boot is going
forward :)

> echo 'rootflags=compr=zlib' > p1/append-GTA02

Are you sure qi is really reading this? i am sure it is not.

> No joy. 
> Same result: kernel complains that lzo is not compiled in. 

It is really not compiled in, and it is OK, you have no need in lzo ATM
in qtmoko.

> Maybe it misses some modules? Maybe I shell put them in "identity-ext2"?
> Have to research more...

No, you need ensure that this options REALLY passed to kernel somehow. I
almost sure they not.

> BTW tried Gennadys script to decode u-boot
> environment(http://www.bsdmn.com/openmoko/gpsfix/env/envedit.pl).
> It complains that crc32 function is not defined.

It is not mine, it is part of
http://svn.openmoko.org/trunk/src/host/devirginator/ and uses crc32 from
it, it's not good idea to get random files from server and complain they
not working :)

> Can I modify u-boot environment from QtMoko running from SD?

u-boot can boot any known distro without problems, from sd, ubi or
jffs2. in hard cases of unusual fses you can just put kernel to splash
NAND partition (named 'depr' in your qi) and boot it with rootfs on sd.

I think it is also possible to make such config that appends kernel
params load from file on external fs, like in qi, but who needs this...

If you need some help in u-boot setup, you can join #qtmoko at freenode

If you really enjoy Qi, use radek's qi from qtmoko site
http://sourceforge.net/projects/qtmoko/files/Experimental or fix kernel
parameters in qi source code and recompile it.


More information about the community mailing list