Freerunner can now play Ogg video

Radek Polak psonek2 at
Mon Jan 18 16:20:20 CET 2010

Timo Juhani Lindfors wrote:

> With mplayer from debian unstable videos created with
> ffmpeg2theora -x 320 -y 240 --videoquality 3 --speedlevel 2 --audioquality
>  3 --samplerate 22050
> do not play smoothly even with "-nosound".

Same here. I think my video had lower bitrate and fps, i appended

-V 300 -F 15

and it plays ok now. Maybe my test ogv had different audio codec (accidentally 
deleted it). IIRC debian mplayer uses floating point implementation for 
decoding ogg so it's crappy. But after compiling with integer only ogg decoder 
it should be ok. I'll have to try it.
> I am using andy-tracking a3587e4ed77974ad with DEBUG and PREEMPT
> disabled with Xorg and xserver-xorg-video-fbdev -- are you perhaps
> using xserver-xorg-video-glamo instead?

No, for sure it was fbdev.



More information about the community mailing list