[QtMoko] How to update TangoGPS maps?

arne anka openmoko at ginguppin.de
Tue Jan 19 12:26:32 CET 2010

> neo:~# dpkg -i yaouh_0.5.1.4_all.opk
> Selecting previously deselected package yaouh.
> (Reading database ... 15461 files and directories currently installed.)
> Unpacking yaouh (from yaouh_0.5.1.4_all.opk) ...
> dpkg: dependency problems prevent configuration of yaouh:
>  yaouh depends on python-pygtk; however:
>   Package python-pygtk is not installed.
> dpkg: error processing yaouh (--install):
>  dependency problems - leaving unconfigured
> Errors were encountered while processing:
>  yaouh

yeah, common issue.
ipk package names do not always match debian package names (this one most  
likely should be python-gtk2).
three ways are possible
- install with ignore-deps, but the package will always turn up as  
"broken" and maybe apt-get will trip over it:
dpkg -i  --ignore-depends=pygtk yaouh_0.5.1.4_all.opk
- unpack the ipk with
ar x  yaouh_0.5.1.4_all.opk
(should extract two tar.gz), find the necessary file(s) and put them into  
- create a dummy  python-pygtk package to satisfy the dependency. there's  
a debain tool exactly for that purpose, but i can't remember the name  
right now. you could even simply create directory structure mimicing eg  
/usr/local/, create a tar.gz from it and create the dummy with alien.

i'd use the second approach ...

More information about the community mailing list