[debian/fso] autosuspend does not work anymore

arne anka openmoko at ginguppin.de
Wed Jan 27 20:04:11 CET 2010

> In fact, I did my upgrade a week or so ago, and at first I could turn off
> the auto-suspend switch in the power settings screen, but it would still
> suspend regardless.  Now it doesn't even let me slide the switch to the  
> off position.  I slide it, but it goes back to the on position.

you're talking about illume?

> directly editing the config file (frameworkd.conf).

when you indeed in the last week or so, you will now need/have a config  
file etc/freesmartphone/fsodeviced.conf whcih now should contain those  
mine reads there (only an extract)

idle = 5
idle_dim = 10
idle_prelock = 6
lock = 2
suspend = 1

> My values are still in the config file, but they are never used in the
> system.  When I try to set them via the UI, they don't update.

i seem to recall a mail stating, that the settings in illume do not  
survive a restart of illume.

after reinstalling the default config files from the current  
fso-config-gta02 package (it seems virtually impossible to replace the  
files by using dpkg with any combination of parameters. i had to remove  
all files manually and use --force-confmiss) and making only the absolut  
necessary changes (log files, log level, calypso sleep, rule for power  
button), it _seems_ to work now.

More information about the community mailing list