[SHR-t] navit crashes with Reiseplanner maps while searching for a town

Xavier Cremaschi omega.xavier at gmail.com
Fri Jan 29 07:55:00 CET 2010

Martin Jansa a écrit :
> On Thu, Jan 28, 2010 at 04:33:21PM +0100, neo at el-hennig.de wrote:
>>> Then this is probably another issue for you, because the regression in 
>>> M&G (reiseplanner) was caused by the use of new tags in OSM which 
>>> weren't added to M&G.
>>> Does your OSM map version match navit's revision? If you use an old OSM 
>>> map, or a newer OSM map with a given revision of navit, it may fail to 
>>> work because of changes in the datas.
>> the planet.bin I use is from January 15th.
>>> BTW : there are daily build of navit for the FR here : 
>>> http://download.navit-project.org/navit/openmoko/svn/
>>> They are built nightly, but it's also possible to trigger a build during 
>>> the day.
>> I know! The problem is that in the SHR feeds the navit packages have an additional versioning which allows the installation of the svn packages only, if you disable the feeds before.
> Please test it from this files and let me know.. if everything works
> I'll push it to oe.dev and then build it in official shr-u feeds.
> (change preferred locale)
> Upgrading navit on root from 1:0.1.0+svnr2902-r5.4.4 to 1:0.1.0+svnr2934-r5.4.4...
> Downloading http://jama.homelinux.org/org.openembedded.shr/armv4t/navit_0.1.0+svnr2934-r5.4.4_armv4t.ipk
> Upgrading navit-locale-cs on root from 1:0.1.0+svnr2902-r5.4.4 to 1:0.1.0+svnr2934-r5.4.4...

> Downloading http://jama.homelinux.org/org.openembedded.shr/armv4t/navit-locale-cs_0.1.0+svnr2934-r5.4.4_armv4t.ipk
> Upgrading navit-icons on root from 0.1.0+svnr2871-r1.4 to 0.1.0+svnr2927-r1.4...
> Downloading http://jama.homelinux.org/org.openembedded.shr/all/navit-icons_0.1.0+svnr2927-r1.4_all.ipk
> Cheers,

SHR-t here, so I cannot test :(
But I really hope it will solve the pb !

Collected errors:
  * ERROR: Cannot satisfy the following dependencies for navit:
          *  libgthread-2.0-0 (>= 2.22.4) *  libgmodule-2.0-0 (>= 
2.22.4) *  libglib-2.0-0 (>= 2.22.4) *  libgio-2.0-0 (>= 2.22.4) * 
libpixman-1-0 (>= 0.17.4) *  libpng12-0 (>= 1.2.41) *  libgobject-2.0-0 
(>= 2.22.4) *  libsdl-image-1.2-0 (>= 1.2.10) *

More information about the community mailing list