cpu reclocking to 500Mhz, overclocking to 533Mhz, performance tests and bootloader images

Gennady Kupava gb at bsdmn.com
Thu Jul 1 11:01:37 CEST 2010


> have you been able to test for stability over a few days of normal

I am using mostly 533/88/clk2 now and over versions for may be 5 days.
So far i have no problems. I run tests on all recommended versions, also
run cpu-intensive video decoding without problems. But i'm on .34 and
can't test some features, like suspend, sound, gsm, but things i tested
works good (usb, glamo video and mmc, cpu). I tried qtmoko and it were
working for 450 version.

Freerunner feels warmer, so i measured temperature, but without opening
that shielding. While 100% cpu load shield temperature is 32C.

Also i noticed it can't stand overnight without usb and suspend due to
bigger power consumption, but with suspend this should be ok.

i know 3 people who tryed it. one were unable to run any clk2 versions,
so he tried 533/clk3. but he very able to run 465 version with default
1.8 on memory bus.

One man reported he is unable to suspend, may be kernel need some fixes
to suspend/resume properly, but currently my .34 can't suspend more than
once anyway, so i didn't test this.

So far no unrecoverable errors reported. No fried frs. One man reported
"flash error" but this turned out to be bad sector on NAND, and he begun
experiments on NAND after changing clock, and we were unable to
attribute this to overclocking.

>I will need to patch/recompile my kernel besides
flashing a new Uboot.

No, you need to recompile/patch kernel only for versions with modified memory 
bus voltage (forth number, if prefent in file name and != 1.8), 
so 533/88, 500/83 versions may be tried without patches.

If you not were familiar with u-boot, here is instruction:
1. flash u-boot environment:
from nor u-boot on fr:
sudo dfu-util -a u-boot_env -D u-boot_env.in
2. check if default u-boot can boot you system and become familiar with environment:
power off, boot with pressing power and in 0.5 sec holding aux for a while.
3. flash reclocked u-boot:
sudo dfu-util -a u-boot -D u-boot.udfu_533_88_1.7_1.8_CLK2
4. try to boot it in similar way.
if not boots, try u-boot.udfu_533_88_1.7 , you may try also with more risk
u-boot.udfu_465_116_1.65_1.9 this may work without kernel patch.


More information about the community mailing list