Flashing qi broke my freerunner

Helge Hafting helge.hafting at hist.no
Tue Jul 20 16:52:02 CEST 2010

On 20. juli 2010 09:17, ghislain wrote:
> I've applied the glamo patch to the qi-bootloader I use for the QtMoko
> installer-images. You can download the qi-bootloader here [1].
> It replaces the qi.img file in the installer image so you can reflash with
> this new bootloader.
> It is, of course, also possible to flash this new bootloader using dfu-util

I tried this. Downloaded qi-s3c2442-master_c38b062a609f1442.udfu, 
flashed it with dfu-util. Command:
dfu-util -a u-boot -R -D qi-s3c2442master_c38b062a609f1442.udfu

On reboot, the screen went white, and nothing more happened.

Unfortunately, there seems to be no way of fixing it. I can download 
other qi versions and flash them. But none works. The screen just goes 
black. For some versions, the vibrator will sound every 10s or so.

Booting through NOR doesn't work, probably because the kernel is bigger 
than 2M. So qi is needed, but seems impossible to get working.

Am I doing this wrong? One of my qi files is the one that worked before. 
But not now. Is there hope of using this device any more?

Helge Hafting

More information about the community mailing list