Some questions to new SHR images (ubifs, gps)

David Garabana david at
Mon Jul 26 20:43:20 CEST 2010

O Luns, 26 de Xullo de 2010 11:13:09 Helge Hafting escribiu:
> On 23. juli 2010 21:43, David Garabana wrote:
> > O Venres, 23 de Xullo de 2010 21:25:50 Sylvain Paré escribiu:
> >> I take this thread about GPS to give my feed back too.
> >> 
> >> > From my personal feedback I will not speak about half a year but since
> >>> 
> >>> March
> >> 
> >> or so
> >> And I do make it works but it takes more time the first time after a
> >> fresh flashed image PLUS
> >> the gps is less sensitive like the signal was weak ( It fixes less
> >> satellites)
> > 
> > Also, with latest images, I cannot get a fix after a suspend.
> Do you suspend with the gps active, (i.e. tangogps running)
> or do you have this problem after any suspend?

It's after *any* suspend.
Even after a clean boot, if I suspend before doing anything else, GPS doesn't 

> I use my FR as a phone, so it is suspended most of the time.
> But the gps always work fine when I use it. I never suspend with
> the gps in use though. If I do that accidentally, I close every
> gps-using app, and then restart them. And the gps works after a little
> while.
> I use shr unstable. I upgrade now and then, but haven't flashed
> for a long time now.

That's the only difference I see between your installation and mine.
I flashed a new image on NAND when SHR jumped to 2.6.32. It was then when GPS 
started to fail.

> > I have to restart to get a fix again.
> > I cannot even see "time" on "shr-settings-position"
> > 
> > It's so sad, because gps was the only rock solid funtionality on my Neo
> > since OM2008 series.
> Well, try closing shr-settings, tangogps, navit, and whatever you may
> have that uses the gps. The freerunner should then power down the
> unused gps to save power. When you start some gps app after that,
> the gps will be properly initialized and ought to work.
> If this helps you, then consider preventing suspend while the gps is in
> use. This workaround works for me. I often use the gps for making track
> logs anyway, so I need to have the cpu running.

I have tried it, and it doesn't help at all.
I have also tried to boot FR without SD, without SIM, and without both (I'm 
currently having problems with my uSD). 
No sucess at all. I have also tried to clean AGPS data. I have waited for 
about 15 minutes for a fix, and I couln't get even time from GPS satellites.
After a suspend, my GPS doesn't work at all, no matter what I do :(

> Instead of launching "tangogps", launch "fsoraw -r CPU tangogps"
> That way, the phone won't suspend until tangogps quits.

That's what I'm doing. I'm not letting FR suspend, forbidding it from quick 
settings, but battery drains very quickly.
Other solution could be boot FR every time I needed to track something, but 
it's not so practical ;)

More information about the community mailing list