glamo baclight

mobi phil mobi at
Wed Mar 31 04:40:46 CEST 2010

FYI: from dmesg below. Strange is the error message:

JBT not initialised!!! ... however I have the corresponding drivers:


# CONFIG_MFD_MC13783 is not set
# CONFIG_AB3100_CORE is not set
# CONFIG_EZX_PCAP is not set
# CONFIG_MFD_GLAMO_FB is not set

S3C24XX DMA Driver, (c) 2003-2004,2006 Simtec Electronics
DMA channel 0 at c8808000, irq 33
DMA channel 1 at c8808040, irq 34
DMA channel 2 at c8808080, irq 35
DMA channel 3 at c88080c0, irq 36
S3C244X: Clock Support, DVS off
s3c24xx-pwm s3c24xx-pwm.0: tin at 25000000, tdiv at 25000000, tin=divclk, base 0
s3c24xx-pwm s3c24xx-pwm.1: tin at 25000000, tdiv at 25000000, tin=divclk, base 8
s3c24xx-pwm s3c24xx-pwm.3: tin at 8333333, tdiv at 8333333, tin=divclk, base 16
bio: create slab <bio-0> at 0
s3c-i2c s3c2440-i2c: slave address 0x10
s3c-i2c s3c2440-i2c: bus frequency set to 97 KHz
pcf50633 0-0073: Probed device version 19 variant 132
regulator: auto: 3300 mV normal
regulator: down1: 1300 <--> 1600 mV normal
regulator: down2: 1800 mV normal
regulator: ldo1: 3300 mV normal
regulator: ldo2: 3300 mV normal
regulator: ldo3: 3000 mV normal
regulator: ldo4: 3200 mV normal
regulator: ldo5: 3000 mV normal
regulator: ldo6: 3000 mV normal
regulator: hcldo: 2000 <--> 3300 mV normal
regulator: memldo: 1800 mV normal
wake enabled for irq 53
s3c24xx-pwm s3c24xx-pwm.2: tin at 8333333, tdiv at 8333333, tin=divclk, base 12
s3c-i2c s3c2440-i2c: i2c-0: S3C I2C adapter
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 4096 (order: 3, 32768 bytes)
TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
TCP: Hash tables configured (established 4096 bind 4096)
TCP reno registered
NET: Registered protocol family 1
gta02-pm-bt gta02-pm-bt.0: Openmoko Freerunner Bluetooth Power
Management: starting
gta02-pm-gps gta02-pm-gps.0: starting
gta02-pm-wlan gta02-pm-wlan.0: starting
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
msgmni has been set to 246
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler deadline registered (default)
[drm] Initialized drm 1.1.0 20060810
s3c2440-uart.0: s3c2410_serial0 at MMIO 0x50000000 (irq = 70) is a S3C2440
s3c2440-uart.1: s3c2410_serial1 at MMIO 0x50004000 (irq = 73) is a S3C2440
s3c2440-uart.2: s3c2410_serial2 at MMIO 0x50008000 (irq = 76) is a S3C2440
glamo3362 glamo3362.0: Glamo core PLL1: 49119232Hz, PLL2: 89980928Hz
glamo-mci glamo-mci.0: glamo_mci driver (C)2007 Openmoko, Inc
glamo-mci glamo-mci.0: glamo_mci_set_ios: power down.
[glamo-drm] SMedia Glamo Direct Rendering Support
[glamo-drm] 8187904 bytes of VRAM
[glamo-drm] Allocated 480x640 fb: bo c791d900
JBT not initialised!!!
[drm] DAC-5: set mode 480x640 6
Console: switching to colour frame buffer device 80x58
[glamo-drm] fb0: glamodrmfb frame buffer device
[glamo-drm] Registered panic notifier
[drm] Initialized glamo-drm 0.1.0 20090614 on minor 0
glamo-mci glamo-mci.0: powered (vdd = 21) clk: 0kHz div=0 (req: 0kHz).
Bus width=0
physmap platform flash device: 00200000 at 18000000
physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank
 Intel/Sharp Extended Query Table at 0x0039
 Intel/Sharp Extended Query Table at 0x0039
 Intel/Sharp Extended Query Table at 0x0039
 Intel/Sharp Extended Query Table at 0x0039
 Intel/Sharp Extended Query Table at 0x0039
cfi_cmdset_0001: Erase suspend on write enabled
erase region 0: offset=0x0,size=0x2000,blocks=8
erase region 1: offset=0x10000,size=0x10000,blocks=31
physmap-flash.0: 1 set(s) of 1 interleaved chips --> 4 partitions of 512 KiB
RedBoot partition parsing not available
S3C24XX NAND Driver, (c) 2004 Simtec Electronics
s3c24xx-nand s3c2440-nand: mapped registers at c9400000
result 0 from 100000, 0
result 3 from 100000, 25
result 2 from 100000, 15
s3c24xx-nand s3c2440-nand: Tacls=1, 10ns Twrph0=3 30ns, Twrph1=2 20ns
s3c24xx-nand s3c2440-nand: NF_CONF is 0xc21e
initialising set 0 (c791a400, info c791e860)
s3c24xx-nand s3c2440-nand: NAND soft ECC
NAND device: Manufacturer ID: 0xec, Chip ID: 0xaa (Samsung NAND 256MiB
1,8V 8-bit)
s3c24xx-nand s3c2440-nand: chip c791a588 => page shift 11
6 cmdlinepart partitions found on MTD device neo1973-nand
Creating 6 MTD partitions on "neo1973-nand":
0x000000000000-0x000000040000 : "qi"
glamo-mci glamo-mci.0: powered (vdd = 21) clk: 399kHz div=0 (req:
400kHz). Bus width=0
0x000000040000-0x000000080000 : "depr-ub-env"
0x000000080000-0x000000880000 : "kernel"
0x000000880000-0x000000920000 : "depr"
glamo-mci glamo-mci.0: powered (vdd = 21) clk: 399kHz div=0 (req:
400kHz). Bus width=0
0x000000920000-0x000000960000 : "identity-ext2"
0x000000960000-0x000010000000 : "rootfs"
glamo-mci glamo-mci.0: powered (vdd = 21) clk: 399kHz div=0 (req:
400kHz). Bus width=0
initialised ok
s3c2410_udc: debugfs dir creation failed -19
s3c2440-usbgadget s3c2440-usbgadget: S3C2440: increasing FIFO to 128 bytes
usb0: MAC 00:1f:11:01:67:82
usb0: HOST MAC 00:1f:11:01:67:83
g_ether gadget: Ethernet Gadget, version: Memorial Day 2008
g_ether gadget: g_ether ready
mice: PS/2 mouse device common for all mice
s3c2440-ts s3c2440-ts: Starting
s3c2440-ts s3c2440-ts: Created Group filter len:12 coords:2 close:10 thresh:6
s3c2440-ts s3c2440-ts: Created Median filter len:20 coords:2 dec_threshold:24
s3c2440-ts s3c2440-ts: Created Mean filter len:4 coords:2
s3c2440-ts s3c2440-ts: Created Linear filter coords:2
s3c2440-ts s3c2440-ts: 4 filter(s) initialized
s3c2440-ts s3c2440-ts: Successfully loaded
input: s3c2410 TouchScreen as /class/input/input0
input: PCF50633 PMU events as /class/input/input1
pcf50633-rtc pcf50633-rtc: rtc core: registered pcf50633-rtc as rtc0

> tried to build on gdrm-2.6.32, but backlight is gone... I seems that
> if I build with the obsolete xxxx_glamo_fb, then it works...

mobi phil

being mobile, but including technology

More information about the community mailing list