Sandisk 16GB SDHC not mountable

Christian Rüb christian.rueb at
Sun Oct 3 11:16:02 CEST 2010

Thanks for offering help.

2010-10-02 01:28:02 Alfa21:
> 2010-10-02 at 20:04 Christian Rüb
> > I partitioned my 16GB SDHC (class 2) card
> have you tried to use it as raw storage? (no filesystem)
> cat plaintextfile.txt > /dev/mmcblk0p1
> less -f /dev/mmcblk0p1

I could not read it back, but using /dev/mmcblk0 it showed up somewhere near the beginning (it was cat to /dev/mmcblk0p1 though)

> you should be able to read your contents of the original input file.
> if you fail to less it on the FR, try the second command on your PC.

showed up at partition start

> try the same directly on /dev/mmcblk0 but this will destroy all your data on uSD (partition table &Co.)

I saw the contents only once and about at the same place when catting it to /dev/mmcblk0p1 (Freerunner)
Once at the beginning and once about where 1 partitions starts (PC).

> have you tried with a whole different fs, like fat32?

same result :( (Freerunner)
On my PC FAT32 and ext3 work ...

Note that I booted using Qi and system is on NAND (kernel 2.6.29)


More information about the community mailing list