Sandisk 16GB SDHC not mountable

Jan Vlug jan.public at
Sun Oct 3 18:08:33 CEST 2010

 I have problems with my uSD as well since 2.6.32
See this ticket:
I had no time to test the suggestion in this ticket yet.

Best regards,

On 10/02/2010 08:04 PM, Christian Rüb wrote:
> Hi,
> I partitioned my 16GB SDHC (class 2) card, so I had a 512MB ext3 primary partition as /dev/mmcblk0p1, but Qi would not boot from it.
> So I booted my NAND system (older SHR-U, 1.6.29 kernel) which shows me correct partition with fdisk -l but would not mount it.
> I recreated the filesystem with mkfs.ext3 on freerunner but it still would not mount it. fsck could not even check the fs:
> e2fsck -f -C0 /dev/mmcblk0p1 
> e2fsck 1.41.9 (22-Aug-2009)
> e2fsck: Superblock invalid, trying backup blocks...
> e2fsck: Bad magic number in super-block while trying to open /dev/mmcblk0p1
> The superblock could not be read or does not describe a correct ext2
> filesystem.  If the device is valid and it really contains an ext2
> filesystem (and not swap or ufs or something else), then the superblock
> is corrupt, and you might try running e2fsck with an alternate superblock:
>     e2fsck -b 8193 <device>
> Trying the fsck suggestion to use an alternate superblock did not help either.
> I then created a partition and filesystem over the whole disk, but same result. No chance to even check the filesystem.
> I also tried to switch back from Qi with glamo 242 to the old one - still no success.
> In my 2 card readers the card does work though.
> Does anyone of you have any ideas?
> Thanks,
>  Christian
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list