QTMoko predictive keyboard weirdness

Alfa21 freerunner at my.is.it
Tue Oct 12 23:34:10 CEST 2010

2010-10-12 at 18:19 Iain Nicol

> Daniel Weatherill wrote, a long time ago:
> > I have a few questions about QTMoko predictive keyboard. I know
> > prediction was disabled by default a couple of versions ago, I
> > understand this as most people are not english speakers.
> > 
> > However, some of us ARE english speakers and found the predictive
> > keyboard very good [. . . ] Can someone help me with this?
> On the off change you're still interested, I found the setting last
> night by reading through the source. :-).  I'm running a clean install
> of QtMoko 26.
> ssh onto your Freerunner and then type:
> cd /home/root/Settings/Trolltech
> cp /opt/qtmoko/etc/default/Trolltech/PredictiveKeyboard.conf .
> echo "unpredictive=0" >> PredictiveKeyboard.conf
> Cheers,
> Iain

I think you can do the same also through the GUI in qtmoko:
settings -> language
[your language] -> use for input -> checked

but it seems not deactivable on the default language (the check box is locked on true) and if you select a secondary language the selection is switched back on false when you leave the dialog window.

btw only my "docked" keyboard is predictable, but suggestions are showed only on the first half of the bar on the top of it.

ok, I realized only now you are talking about the "predictive" keyboard and I thought only the docked one to have this feature :P sorry, I need to go to sleep! (dreaming for a bed)

but the above one seems to be a bug in lang. config gui, is it?


More information about the community mailing list