Using freerunner as webcam display

Denis Shulyaka shulyaka at
Sat Sep 4 21:51:43 CEST 2010

2010/9/3 Alexander Lehner <lehner at>:
> On Fri, 3 Sep 2010, Gennady Kupava wrote:
>> ? ???, 03/09/2010 ? 19:03 +0200, Alexander Lehner ?????:
>>> I think it's the CPU which is around 90% already at 2fps.
>>> Another problem is, that the mpeg stream sometimes seems to be corrupt
>>> which crashess mplayer after some time.
>>> So I did a 'while true; do mplayer...; done' around and set codecs and
>>> other parameters by hand to avoid the autodetection.
>> Hey, do not scarify this man with timings, theora, omhacks and etc. I
>> can play  640*480 mpeg2 at 12fps, glamo can update 640x480 fullscreen at
>> much higher fps ;)
>> 2 fps is way too low, you should find what is missing.
>> What is resolution? what is codec, can you rstp service send in
>> different format (may be mpeg4 will be faster)? Do you sending sound
>> with your image? Which part of system eats 90% of CPU?
>> Caclulate your rate and find out why it is so slow, find out why it is
>> so slow!
> I turned back the fps of the cam to 10fps and it still works, i.e. I don't
> have framedrops and CPU load is the same (ok, there is not much room
> left...)
> BUT: the reaction is too slow. If i move the cam, it takes up to 15
> seconds, until the actual image appears.
> It seems that there is some data stuck somewhere, but I don't know where.
> If I watch the cam from a PC, I don't see that delay.
> The webcam sends a sound, but i've turned sound off in mplayer.
> The resolution is 640x480.
> It's mplayer itself which eats all CPU.
> The only alternative is MJPEG which does not work, so I'm using MPEG4 (did
> I say MPEG2 before?).
> My FR is connected via WiFi (someone said it's faster than USB) and next
> to the accesspoint.
> My mplayer line looks like:
> mplayer -vc ffodivx -vf scale -fps 2 -fs -nosound -vf rotate=2 -vo fbdev rtsp://doorspy:554/mpeg4
> And that's what mplayer says:
> ------
> Playing rtsp://doorspy:554/mpeg4.
> Resolving doorspy for AF_INET...
> Connecting to server doorspy[]: 554...
> rtsp_session: unsupported RTSP server. Server type is 'unknown'.
> STREAM_LIVE555, URL: rtsp://doorspy:554/mpeg4
> Stream not seekable!
>  file format detected.
> Initiated "video/MP4V-ES" RTP subsession on port 53728
> Initiated "audio/PCMU" RTP subsession on port 58282
> VIDEO:  [mp4v]  0x0  0bpp  0.000 fps    0.0 kbps ( 0.0 kbyte/s)
> Opening video filter: [rotate=2]
> ==========================================================================
> Forced video codec: ffodivx
> Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
> Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
> ==========================================================================
> Audio: no sound
> FPS forced to be 2.000  (ftime: 0.500).
> Starting playback...
> Could not find matching colorspace - retrying with -vf scale...
> Opening video filter: [scale]
> Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
> [swscaler @ 0x40e90890]No accelerated colorspace conversion found from yuv420p to rgb565le.
> ----------
> Alex.
> _______________________________________________
> Openmoko community mailing list
> community at

Hi Alex!

I think that video filters you use take too much cpu. Try -zoom
instead of -vf scale and also try `xrandr -o 2` before running mplayer
and omit the -vf rotate=2 parameter. Also try -vo x11 if above does
not work.


More information about the community mailing list