[Shr-User] uSD hosed, on every unstable.

jeremy jozwik jerjoz.forums at gmail.com
Wed Sep 8 19:16:00 CEST 2010

On Wed, Sep 8, 2010 at 10:06 AM, Al Johnson <alastair at truebox.co.uk> wrote:
> Assuming Joachim's correct about it not mattering if you use 0:1 or 1:1 it
> looks like u-boot can't access your SD cleanly either, and it may be an
> intermittent problem since with both ext2ls and mmcinit you sometimes get the
> error lines and sometimes not. It will probably take a u-boot expert or a
> close look at the code to see what the error means, and possibly sight of the
> glamo documentation :-(
> It seems like a hardware error to me, though there's a faint possibility it's
> got into some odd state that's being kept alive by the backup battery. All I
> can suggest at this point is to check the contacts on the SD and its socket
> are clean, and try leaving it with the battery out long enough for the backup
> battery to go flat before trying again. I don't know how long that takes, but
> over night should be plenty. If it was long enough the rtc will have lost the
> time. And try mmc 1:1 just in case it makes a difference.

adding openmoko community to the list.

i am experiencing an error on boot when the sd card, 3 different cards
of different capacities.

mmc0 unrecognized SCR structure version 5
mmc0 err -22 whilest initiation sd card.

we have logged into u-boot to see if it can read a partition on the sd card.

GTA02v6 # ext2ls mmc 0:1 /OSM
** Bad partition - mmc 0:1 **
GTA02v6 # mmcinit
Card Type:          SD 2.0 SDHC
Manufacturer:       0x02, OEM "TM"
Product name:       "SD08G", revision 3.8
Serial number:      3226732165
Manufacturing date: 5/2009
MMC/SD size:        3MiB
GTA02v6 #
GTA02v6 # ext2ls mmc 0:1 /OSM

someone else mentioned they were having issues with there card and it
was solved by bending the contact pins to an even hight. i have
already tried that long ago.

anyone on the openmoko list have anything to add to this?

More information about the community mailing list