[Shr-User] uSD hosed, on every unstable.

Al Johnson openmoko at mazikeen.demon.co.uk
Wed Sep 8 21:48:33 CEST 2010

On Wednesday 08 September 2010, jeremy jozwik wrote:
> On Wed, Sep 8, 2010 at 9:50 AM, Gennady Kupava <gb at bsdmn.com> wrote:
> > SD initalisation in kernel look strange and fact that we need
> > different rootwait/rootdelay in kernel, while u-boot can read
> > SD card almost instantly seriously puzzles me.
> > 
> > Also i can notice fact that I have 50% probability of successfull mmc
> > read in u-boot wuth 2-4-2 timings, while 4-4-4 is 100% successfull, may
> > be only in extremly rare cases. This makes me think that some delay (or
> > proper sync) is needed in mmc sequence.
> are you eluding to u-boot accessing the SD card incorrectly? if so,
> how is it that previously locally saved u-boot version used to work.
> and i used to be able to read the SD card within shr.

I think there are two separate issues here.

I think Gennady is correct to say there is something wrong in the kernel 
handling of mmc on the glamo, and probably also something wrong in u-boot. If 
everything was correct we wouldn't need a list of compatible and incompatible 
cards, or parameters to fiddle with delays and clock speeds. This may be 
another case where some study of the glamo documentation and the existing code 
can help. I have a 4G Kingston card that's on the non-compatible list if 
someone wants to try this.

I don't think that is the cause of your issue because your cards used to work, 
but don't any more, with software that used to work for you and still does for 
other people.

More information about the community mailing list